воскресенье, 26 февраля 2012 г.

Проблемы с gemspec типа Illformed requirement Invalid gemspec

Если мы получаем проблемы с Illformed requirement Invalid gemspec при операциях с bundle,

то у меня получилось руками (в vim) пройтись по спекам

specifications/rails-3.2.0.gemspec

 

и выполнить замену YAML:Syck

%s/#<YAML::Syck::DefaultKey:0x.*>/=/

 

само шаманство и причина описаны здесь: http://blog.rubygems.org/2011/08/31/shaving-the-yaml-yak.html

Комментариев нет:

Отправить комментарий